Problem

Beim Versuch eines Exports nach bzw. Imports von Excel, dBase oder Text-Dateien etc. erscheint die o.a. Fehlermeldung (Fehler-Nr. 3170  INSTALLIERBARES ISAM NICHT GEFUNDEN).

 

Ursachen

Dieser Fehler kann durch eine ungültige Information in der Windows-Registrierung oder durch eine fehlende oder defekte Dynamic Link Library (DLL) hervorgerufen werden.

 

Lösungen

  1. Versuchen Sie zuerst eine (Neu-) Installation der entsprechenden Treiber von der Office-CD (Menüpunkt 'Datenzugriff' Textdateien)
  2. Wenn das nicht hilft bzw. der Treiber im Office-Setup-Programm bereits als installiert markiert ist, dann folgen Sie der Anleitung, die es von MS gibt.
    Wenn Sie jedoch das Microsoft Office 97 Setup-Programm starten, um die ISAM-Treiber für diese Anwendungen nachzuinstallieren, sind diese bereits als installiert markiert.

 

MS-Anleitung:

Überprüfen Sie zunächst, ob die folgenden Dateien auf Ihrem Computer installiert sind:

Dateiname

Import/Export ISAM für

MSEXCL35.DLL

Microsoft Excel

MSTEXT35.DLL

Text

MSXBSE35.DLL

dBase

 

Verwenden Sie nun zur Lösung des Problems einen der folgenden Lösungsansätze.

 

Lösungsansatz 1:

Versuchen Sie, die DLL-Dateien mit "Regsvr32.exe" unter START - AUSFÜHREN nachzuregistrieren. Benutzen Sie z.B. die folgende Befehlszeile:
   Regsvr32.exe "C:\Windows\System\Mstext35.dll"
Sollten nach der manuellen Registrierung der erforderlichen Dateien die Treiber noch immer nicht in der Liste der Dateitypen erscheinen, versuchen Sie es mit Lösungsansatz 2.

Hinweis: Für weitere Informationen über die Verwendung von "Regsvr32.exe" lesen Sie bitte den folgenden Artikel aus der Microsoft Knowledge Base:
   Artikel: D38752
   Titel: Access: ActiveX-Steuerelemente registrieren (regsvr32.exe)

 

Lösungsansatz 2:

Versuchen Sie, die ISAM-Treiber zu deinstallieren und dann erneut zu installieren, damit diese richtig registriert werden können:

Wählen Sie START - EINSTELLUNGEN - SYSTEMSTEUERUNG, und doppelklicken Sie auf das Symbol SOFTWARE.
Auf der Registerkarte INSTALLIEREN/DEINSTALLIEREN wählen Sie "Microsoft Office 97, Professional Edition" und klicken dann auf die Schaltfläche HINZUFÜGEN/ENTFERNEN.
Wenn Sie nach der Installations-CD gefragt werden, legen Sie diese in Ihr CD-ROM Laufwerk und klicken auf OK. Danach startet das Microsoft Office 97 Professional Edition Setup-Programm.
Auf dem ersten Bildschirm des Setup-Programms klicken Sie auf HINZUFÜGEN/ENTFERNEN.
In der Auswahlbox wählen Sie "Datenzugriff" und klicken auf die Schaltfläche OPTION ÄNDERN.
In der Liste für den Datenzugriff wählen Sie "Datenbank-Treiber" und klicken auf die Schaltfläche OPTION ÄNDERN.
Deaktivieren Sie jeden Treiber der nicht angezeigt wurde. Klicken Sie hierzu auf das entsprechende Kontrollkästchen.
Klicken Sie zweimal auf OK und dann auf WEITER.

Hinweis: Sollte das Kontrollkästchen für die ISAM Treiber nicht vorhanden sein, klicken Sie dreimal auf ABBRECHEN, zweimal auf BEENDEN und anschließend auf OK, um das Setup-Programm zu beenden. Fahren Sie mit Schritt 10 fort.
Klicken Sie auf JA, wenn Sie danach gefragt werden, ob Sie die Komponenten entfernen möchten.
Bestätigen Sie mit OK, wenn das Setup-Programm erfolgreich beendet wurde.
Lassen Sie die Registerkarte SOFTWARE INSTALLIEREN/DEINSTALLIEREN noch geöffnet.
Starten Sie den Windows Explorer und suchen Sie nach den folgenden Dateinamen:

Dateiname

Import/Export ISAM für

MSEXCL35.DLL

Microsoft Excel

MSTEXT35.DLL

Text

MSXBSE35.DLL

dBase


Benennen Sie diese Dateien um und schließen den Windows Explorer.

Wiederholen Sie die Schritte 2-6.
Markieren Sie jeden Treiber, den Sie erneut installieren wollen.
Klicken Sie zweimal auf OK und dann auf WEITER.
Wenn das Setup Programm die Aktualisierung Ihres Systems beendet hat, klicken Sie auf OK. Schließen Sie die Registerkarte SOFTWARE INSTALLIEREN/DEINSTALLIEREN.

 

Hinweis:

ISAM-Treiber ermöglichen den Zugriff auf externe Datenbankformate. ISAM steht für Indexed Sequential Access Method (Indexsequentielle Zugriffsmethode).